Topic-icon Question Douglas A_20 Havoc

1 year 2 months ago #809 by frederi350

I downloaded the Douglas A_20 Havoc after disconnecting all of my computer's safety features ( Norton and User Account Control). The download and Installation where successful. After loading FSX I could not find the Havoc in the Aircraft Selection Window. I am using FSX Booster 2013-Version 2.9 to start FSX and I also tried starting FSX without using the Booster 2013. I also tried rebooting. Then I tried reloading FSX Flight Simulator Deluxe Edition from the DVD Disk using the Maintenance feature. I have FSX loaded on my D: data disk not the C: local disk in Program Files(x86) / Microsoft Games. I also tried reinstalling several times using the Automatic Installation and the Custom Installation. Nothing I do seems to want to bring up the Douglas A_20 Havoc in the Aircraft Selection Window.
I am running
Windows 10
Processor: Intel(R) Core(TM) i7 4790K CPU @4.00 GHz
Installed Memory (RAM): 16.0 GB (15.9 Usable)
System Type: 64 -bit Operating System, x64-based Processor
Display Adapters: NVIDIA GeForce GTX 970 and Intel(R) Graphics 4600

The following user(s) said Thank You: papy68

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add Files.
  • Not Allowed: to edit your message.
Moderators: Gh0stRider203
Time to create page: 0.098 seconds